using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\]\)]),(\s*\n*\s*)([\]\)])";
string input = @"[[
'id' => 'palette-3',
'color1' => [ 'color' => '#3eaf7c' ],
'color2' => [ 'color' => 'rgb(207, 216, 225)' ],
'color3' => [ 'color' => '#f0f0f0' ],
'color4' => [ 'color' => '#c8c8c8' ],
'color5' => [ 'color' => '#f0f0f0' ],
],
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}