package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\]\)]),(\s*\n*\s*)([\]\)])`)
var str = `[[
'id' => 'palette-3',
'color1' => [ 'color' => '#3eaf7c' ],
'color2' => [ 'color' => 'rgb(207, 216, 225)' ],
'color3' => [ 'color' => '#f0f0f0' ],
'color4' => [ 'color' => '#c8c8c8' ],
'color5' => [ 'color' => '#f0f0f0' ],
],
]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}