import Foundation
let pattern = #"data:((?<contenttype>[a-z\-]+\/[a-z\-.]+){1}(;[a-z\-]+\=[a-zA-Z0-9\-]+)?){1}(;filename=(?<passedFileName>[a-zA-Z0-9\-\._]*))(;base64,){1}(?<content>[a-zA-Z0-9\!\$\&\'\,\(\)\*\+\,\;\=\-\.\~\:\@\/\?\%\s]*)_"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am.txt;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)