// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)data:((?<contenttype>[a-z\-]+\/[a-z\-.]+){1}(;[a-z\-]+\=[a-zA-Z0-9\-]+)?){1}(;filename=(?<passedFileName>[a-zA-Z0-9\-\._]*))(;base64,){1}(?<content>[a-zA-Z0-9\!\$\&\'\,\(\)\*\+\,\;\=\-\.\~\:\@\/\?\%\s]*)_").unwrap();
let string = "data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am.txt;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC
_
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}