# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"data:((?<contenttype>[a-z\-]+\/[a-z\-.]+){1}(;[a-z\-]+\=[a-zA-Z0-9\-]+)?){1}(;filename=(?<passedFileName>[a-zA-Z0-9\-\._]*))(;base64,){1}(?<content>[a-zA-Z0-9\!\$\&\'\,\(\)\*\+\,\;\=\-\.\~\:\@\/\?\%\s]*)_"
test_str = ("data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC\n"
"_\n\n"
"data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;filename=am.txt;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC\n"
"_\n\n"
"data:application/vnd.openxmlformats-officedocument.wordprocessingml.document;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAIAAAA7ljmRAAAAGElEQVQIW2P4DwcMDAxAfBvMAhEQMYgcACEHG8ELxtbPAAAAAElFTkSuQmCC\n"
"_\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.