re = /<a.*?href = "\/(.+?)\/">.*?<\/a>/m
str = '<a href = "/csharpmarc.net/">Csharpmarc.net</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end