$re = '/<a.*?href = "/(.+?)/">.*?</a>/m';
$str = '<a href = "/csharpmarc.net/">Csharpmarc.net</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);