package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a.*?href = "/(.+?)/">.*?</a>`)
var str = `<a href = "/csharpmarc.net/">Csharpmarc.net</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}