# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(droit d'entr[ée]e)\s?(\W|du|de|fix[eé] [aà]|[aà]|est de)? (\d+.\d+|\d+\s\d+)"
test_str = ("[DROIT D'ENTREE]\n\n"
"droit d'entrée de 100000 € \n"
"droit d'entrée : 100 000€ \n"
"droit d'entrée à 150 000 € \n"
"droit d'entrée 102000€ \n"
"droit d'entrée = 200.000 € \n"
"droit d'entrée fixé à 200000 € \n"
"droit d'entrée fixé à 200000 EUR\n"
"droit d'entrée fixé à 200000 euro\n"
"droit d'entrée : nous consulter \n"
"Prix droit d'entrée : 230 000 euros net vendeur\n"
"droit d'entrée : 100 000 euros HD\n"
"Prix droit d'entrée : 26 000 euros honoraires à charge vendeur\n"
"droit d'entrée : 100 000 euros FAI\n"
"droit d'entrée : 298.000euros honoraires charge vendeur.\n"
"la droit d'entrée est de 85 000 euros Hors Honoraires\n"
"droit d'entrée de 23 000€ net vendeur\n"
"droit d'entrée 62 000 euros\n\n"
"[NE PAS PRENDRE EN COMPTE]\n\n"
"pas de droit d'entrée\n"
"sans droit d'entrée\n"
"sans aucun droit d'entrée \n"
"aucun droit d'entrée \n"
"pas de droit d'entrée \n"
"droit d'entrée : néant \n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.