use strict;
my $str = '[DROIT D\'ENTREE]
droit d\'entrée de 100000 €
droit d\'entrée : 100 000€
droit d\'entrée à 150 000 €
droit d\'entrée 102000€
droit d\'entrée = 200.000 €
droit d\'entrée fixé à 200000 €
droit d\'entrée fixé à 200000 EUR
droit d\'entrée fixé à 200000 euro
droit d\'entrée : nous consulter
Prix droit d\'entrée : 230 000 euros net vendeur
droit d\'entrée : 100 000 euros HD
Prix droit d\'entrée : 26 000 euros honoraires à charge vendeur
droit d\'entrée : 100 000 euros FAI
droit d\'entrée : 298.000euros honoraires charge vendeur.
la droit d\'entrée est de 85 000 euros Hors Honoraires
droit d\'entrée de 23 000€ net vendeur
droit d\'entrée 62 000 euros
[NE PAS PRENDRE EN COMPTE]
pas de droit d\'entrée
sans droit d\'entrée
sans aucun droit d\'entrée
aucun droit d\'entrée
pas de droit d\'entrée
droit d\'entrée : néant
';
my $regex = qr/(droit d'entr[ée]e)\s?(\W|du|de|fix[eé] [aà]|[aà]|est de)? (\d+.\d+|\d+\s\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}