using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(droit d'entr[ée]e)\s?(\W|du|de|fix[eé] [aà]|[aà]|est de)? (\d+.\d+|\d+\s\d+)";
string input = @"[DROIT D'ENTREE]
droit d'entrée de 100000 €
droit d'entrée : 100 000€
droit d'entrée à 150 000 €
droit d'entrée 102000€
droit d'entrée = 200.000 €
droit d'entrée fixé à 200000 €
droit d'entrée fixé à 200000 EUR
droit d'entrée fixé à 200000 euro
droit d'entrée : nous consulter
Prix droit d'entrée : 230 000 euros net vendeur
droit d'entrée : 100 000 euros HD
Prix droit d'entrée : 26 000 euros honoraires à charge vendeur
droit d'entrée : 100 000 euros FAI
droit d'entrée : 298.000euros honoraires charge vendeur.
la droit d'entrée est de 85 000 euros Hors Honoraires
droit d'entrée de 23 000€ net vendeur
droit d'entrée 62 000 euros
[NE PAS PRENDRE EN COMPTE]
pas de droit d'entrée
sans droit d'entrée
sans aucun droit d'entrée
aucun droit d'entrée
pas de droit d'entrée
droit d'entrée : néant
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}