# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>\"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>\"(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\"))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+)@(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+|\[(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-Z^-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\](?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)$"
test_str = "john.smith@example.com"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.