using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>""(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+""))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++|(?>""(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!#-\[\]-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+""))(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+)@(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+(?>\.(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+[\w\d!#-'*+\/=?^`{-~-]++(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)*+|\[(?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-Z^-\x7f]++|\\[\x00-\x7f]))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\](?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>(?>(\((?>(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+(?>[\x01-\x08\x0b\x0c\x0e-\x1f!-'*-\[\]-\x7f]++|\\[\x00-\x7f]|(?-1)))*+(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+\))(?>[ \t]++(?>\r\n[ \t]++)*+|\r\n[ \t]++)?+)++)?+)?+)$";
string input = @"john.smith@example.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}