import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>(?>[\\w\\d!#-'*+\\/=?^`\\{-~-]++|(?>\"(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!#-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\"))(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>\\.(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>[\\w\\d!#-'*+\\/=?^`\\{-~-]++|(?>\"(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!#-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\"))(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)*+)@(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>[\\w\\d!#-'*+\\/=?^`\\{-~-]++(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+(?>\\.(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+[\\w\\d!#-'*+\\/=?^`\\{-~-]++(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)*+|\\[(?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-Z^-\\x7f]++|\\\\[\\x00-\\x7f]))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\](?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>(?>(\\((?>(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+(?>[\\x01-\\x08\\x0b\\x0c\\x0e-\\x1f!-'*-\\[\\]-\\x7f]++|\\\\[\\x00-\\x7f]|(?-1)))*+(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+\\))(?>[ \\t]++(?>\\r\\n[ \\t]++)*+|\\r\\n[ \\t]++)?+)++)?+)?+)$";
final String string = "john.smith@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}