$re = '/(BradMoon-PGT-2017)\-(\d\d)\-(\d\d)\_to\_(2017)\-(\d\d)\-(\d\d)/';
$str = 'BradMoon-PGT-2017-02-04_to_2017-02-10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);