using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(BradMoon-PGT-2017)\-(\d\d)\-(\d\d)\_to\_(2017)\-(\d\d)\-(\d\d)";
string input = @"BradMoon-PGT-2017-02-04_to_2017-02-10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}