package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(BradMoon-PGT-2017)\-(\d\d)\-(\d\d)\_to\_(2017)\-(\d\d)\-(\d\d)`)
var str = `BradMoon-PGT-2017-02-04_to_2017-02-10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}