use strict;
my $str = 'NEM.ESB.IPAB.400.001
NEM.ESB.IPAB.400.003
NEM.ESB.TST.400.1
NEM.BPM.TST.400.1
NEM.ESB.TSTTST.400.1
NEM.BPM.TSTTST.400.1
NEM.ESB.TST.400.001
NEM.BPM.TST.400.001
NEM.ESB.TSTTST.400.001
NEM.BPM.TSTTST.400.001
NEM.ESB.AAA.000.000
NEM.BPM.AAA.000.000
NEM.ESB.AAAAAA.000.000
NEM.BPM.AAAAAA.000.000
NEM.ESB.ZZZ.999.999
NEM.BPM.ZZZ.999.999
NEM.ESB.ZZZZZZ.999.999
NEM.BPM.ZZZZZZ.999.999
ANEM.ESB.TST.400.1
AEM.BPM.TST.400.1
AEM.ESB.TSTTST.400.1
AEM.BPM.TSTTST.400.1
AEM.ESB.TST.400.001
AEM.BPM.TST.400.001
AEM.ESB.TSTTST.400.001
AEM.BPM.TSTTST.400.001
AEM.ESB.AAA.000.000
AEM.BPM.AAA.000.000
AEM.ESB.AAAAAA.000.000
AEM.BPM.AAAAAA.000.000
AEM.ESB.ZZZ.999.999
AEM.BPM.ZZZ.999.999
AEM.ESB.ZZZZZZ.999.999
AEM.BPM.ZZZZZZ.999.999
';
my $regex = qr/^NEM.[A-Z0-9]{3}.[A-Z0-9]{3,6}.[0-9]{3}.[0-9]{1,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}