import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^NEM.[A-Z0-9]{3}.[A-Z0-9]{3,6}.[0-9]{3}.[0-9]{1,3}$";
final String string = "NEM.ESB.IPAB.400.001\n"
+ "NEM.ESB.IPAB.400.003\n\n"
+ "NEM.ESB.TST.400.1\n"
+ "NEM.BPM.TST.400.1\n"
+ "NEM.ESB.TSTTST.400.1\n"
+ "NEM.BPM.TSTTST.400.1\n\n"
+ "NEM.ESB.TST.400.001\n"
+ "NEM.BPM.TST.400.001\n"
+ "NEM.ESB.TSTTST.400.001\n"
+ "NEM.BPM.TSTTST.400.001\n\n"
+ "NEM.ESB.AAA.000.000\n"
+ "NEM.BPM.AAA.000.000\n"
+ "NEM.ESB.AAAAAA.000.000\n"
+ "NEM.BPM.AAAAAA.000.000\n\n"
+ "NEM.ESB.ZZZ.999.999\n"
+ "NEM.BPM.ZZZ.999.999\n"
+ "NEM.ESB.ZZZZZZ.999.999\n"
+ "NEM.BPM.ZZZZZZ.999.999\n\n\n\n\n"
+ "ANEM.ESB.TST.400.1\n"
+ "AEM.BPM.TST.400.1\n"
+ "AEM.ESB.TSTTST.400.1\n"
+ "AEM.BPM.TSTTST.400.1\n\n"
+ "AEM.ESB.TST.400.001\n"
+ "AEM.BPM.TST.400.001\n"
+ "AEM.ESB.TSTTST.400.001\n"
+ "AEM.BPM.TSTTST.400.001\n\n"
+ "AEM.ESB.AAA.000.000\n"
+ "AEM.BPM.AAA.000.000\n"
+ "AEM.ESB.AAAAAA.000.000\n"
+ "AEM.BPM.AAAAAA.000.000\n\n"
+ "AEM.ESB.ZZZ.999.999\n"
+ "AEM.BPM.ZZZ.999.999\n"
+ "AEM.ESB.ZZZZZZ.999.999\n"
+ "AEM.BPM.ZZZZZZ.999.999\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}