re = /^(([0-9]{3})\.?([0-9]{3})\.?([0-9]{3})\-?([0-9]{2})([-])?)$/
str = '013.935.070-50'
# Print the match result
str.match(re) do |match|
puts match.to_s
end