$re = '/^(([0-9]{3})\.?([0-9]{3})\.?([0-9]{3})\-?([0-9]{2})([-])?)$/';
$str = '013.935.070-50';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);