package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([0-9]{3})\.?([0-9]{3})\.?([0-9]{3})\-?([0-9]{2})([-])?)$`)
var str = `013.935.070-50`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}