// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[a-zA-Z]{2}[0-9]{7}[a-zA-Z]{1,3}$").unwrap();
let string = "this_is_a_test
AB1234567F
AB1234567D";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}