package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-zA-Z]{2}[0-9]{7}[a-zA-Z]{1,3}$`)
var str = `this_is_a_test
AB1234567F
AB1234567D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}