$re = '/^[a-zA-Z]{2}[0-9]{7}[a-zA-Z]{1,3}$/mi';
$str = 'this_is_a_test
AB1234567F
AB1234567D';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);