re = /^[\s]*(?!static)[\s]*GS::(|Data|Event|Error|Fatal|Info|Trace|Warning)LogLine[\s]*/m
str = ' static GS::DataLogLine log5 ("File sizes: total: %, meta data partition: %, user data partition: %");'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end