using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\s]*(?!static)[\s]*GS::(|Data|Event|Error|Fatal|Info|Trace|Warning)LogLine[\s]*";
string input = @" static GS::DataLogLine log5 (""File sizes: total: %, meta data partition: %, user data partition: %"");";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}