const regex = /^[\s]*(?!static)[\s]*GS::(|Data|Event|Error|Fatal|Info|Trace|Warning)LogLine[\s]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[\\s]*(?!static)[\\s]*GS::(|Data|Event|Error|Fatal|Info|Trace|Warning)LogLine[\\s]*', 'gm')
const str = ` static GS::DataLogLine log5 ("File sizes: total: %, meta data partition: %, user data partition: %");`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}