// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[\t ]*(?:\r?\n|\r))+").unwrap();
let string = "TITLE ---
=========
Ergo Proxy Sinus Putrid A.D.2049
§ - Chapter 01
Textum Receptus
Holy [link](https://www.unicode.org/index.html)
Image 01-
..
Image 09
§§°ç^?
§ - Chapter 2 %&&&
End.
Loigismo Amonitus Heracleion
Poltrer Hegheist Lotrar Ultreum
Unicus Scribus \"\"\"!€*ù7n
Olk/6
//n
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}