import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\t ]*(?:\\r?\\n|\\r))+";
final String string = "TITLE ---\n"
+ "=========\n\n\n"
+ "Ergo Proxy Sinus Putrid A.D.2049\n"
+ "§ - Chapter 01\n\n\n\n"
+ "Textum Receptus \n"
+ "Holy [link](https://www.unicode.org/index.html)\n\n"
+ "Image 01-\n"
+ "..\n"
+ "Image 09\n\n"
+ "§§°ç^?\n"
+ " § - Chapter 2 %&&&\n\n"
+ "End.\n"
+ "Loigismo Amonitus Heracleion\n"
+ "Poltrer Hegheist Lotrar Ultreum\n\n\n\n\n"
+ "Unicus Scribus \"\"\"!€*ù7n\n"
+ "Olk/6\n\n"
+ "//n\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}