use strict;
my $str = 'TITLE ---
=========
Ergo Proxy Sinus Putrid A.D.2049
§ - Chapter 01
Textum Receptus
Holy [link](https://www.unicode.org/index.html)
Image 01-
..
Image 09
§§°ç^?
§ - Chapter 2 %&&&
End.
Loigismo Amonitus Heracleion
Poltrer Hegheist Lotrar Ultreum
Unicus Scribus """!€*ù7n
Olk/6
//n
';
my $regex = qr/^(?:[\t ]*(?:\r?\n|\r))+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";