$re = '/[\S\w]+\s?:\s?[\S▁]+/m';
$str = '▁h : ▁hour
▁Sheet : ▁[0]
▁sp : Modify';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);