using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\S\w]+\s?:\s?[\S▁]+";
string input = @"▁h : ▁hour
▁Sheet : ▁[0]
▁sp : Modify";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}