re = /[A-Z]\d+/m
str = 'Bill Number: S989610413
Bill Number: D187529186
Bill Number: E103948103
Bill Number: W1230134812
Bill Number: P698129481000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end