import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]\\d+";
final String string = "Bill Number: S989610413\n"
+ "Bill Number: D187529186\n"
+ "Bill Number: E103948103\n"
+ "Bill Number: W1230134812\n"
+ "Bill Number: P698129481000\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}