#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]\d+"
Local $sString = "Bill Number: S989610413" & @CRLF & _
"Bill Number: D187529186" & @CRLF & _
"Bill Number: E103948103" & @CRLF & _
"Bill Number: W1230134812" & @CRLF & _
"Bill Number: P698129481000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")