// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})").unwrap();
let string = "http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related
https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE
https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE
https://www.youtube.com/embed/NMKkz9uRXJc";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}