#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})"
Local $sString = "http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related" & @CRLF & _
"https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE" & @CRLF & _
"https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE" & @CRLF & _
"https://www.youtube.com/embed/NMKkz9uRXJc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")