$re = '/(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})/mi';
$str = 'http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related
https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE
https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE
https://www.youtube.com/embed/NMKkz9uRXJc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);