re = /^((0)*[1-9]|1[012]|3[01])-((0)*[1-9]|1[012]|2[012]|3[01])-(19[0-9][0-9]|20[0-9][0-9])$/m
str = '02-19-2020
12-3-2020
3-12-2020
3-4-1222
31-07-2321
7-7-2083'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end