using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((0)*[1-9]|1[012]|3[01])-((0)*[1-9]|1[012]|2[012]|3[01])-(19[0-9][0-9]|20[0-9][0-9])$";
string input = @"02-19-2020
12-3-2020
3-12-2020
3-4-1222
31-07-2321
7-7-2083";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}