import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((0)*[1-9]|1[012]|3[01])-((0)*[1-9]|1[012]|2[012]|3[01])-(19[0-9][0-9]|20[0-9][0-9])$";
final String string = "02-19-2020\n"
+ "12-3-2020\n"
+ "3-12-2020\n"
+ "3-4-1222\n"
+ "31-07-2321\n"
+ "7-7-2083";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}