re = /(\W)(xtext)/
str = '.art text xtext gg
.fo xtext = U|xtext
dfgtx \'xtext\' gghzu \'U|xtext\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end