$re = '/(\W)(xtext)/';
$str = '.art text xtext gg
.fo xtext = U|xtext
dfgtx \'xtext\' gghzu \'U|xtext\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);