package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\W)(xtext)`)
var str = `.art text xtext gg
.fo xtext = U|xtext
dfgtx 'xtext' gghzu 'U|xtext'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}