re = /\[(\s*[a-z]+\s+([a-z]+\s*)*)*,(\s*[a-z]+\s+([a-z]+\s*)*)*\]/m
str = ' asa [ is his hair , grey or gray ] dsfs df'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end