package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[(\s*[a-z]+\s+([a-z]+\s*)*)*,(\s*[a-z]+\s+([a-z]+\s*)*)*\]`)
var str = ` asa [ is his hair , grey or gray ] dsfs df`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}