$re = '/\[(\s*[a-z]+\s+([a-z]+\s*)*)*,(\s*[a-z]+\s+([a-z]+\s*)*)*\]/m';
$str = ' asa [ is his hair , grey or gray ] dsfs df';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);