$re = '/(^a[a-z]+a$)|(^e[a-z]+e$)|(^i[a-z]+i$)|(^o[a-z]+o$)|(^u[a-z]u+$)/m';
$str = 'agdua';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);