package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^a[a-z]+a$)|(^e[a-z]+e$)|(^i[a-z]+i$)|(^o[a-z]+o$)|(^u[a-z]u+$)`)
var str = `agdua`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}